package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)( +and +)(\w+)( +[^,]*)`)
var str = `Heather Robinson, Jane and John Smith, Kiwan and Nichols Brady John, Jimmy Nichols, Melanie Carbone, and Nancy Brown`
var substitution = "\1\4\2\3\4"
fmt.Println(re.ReplaceAllString(str, substitution))
}