const regex = /(\w+)( +and +)(\w+)( +[^,]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)( +and +)(\\w+)( +[^,]*)', 'gm')
const str = `Heather Robinson, Jane and John Smith, Kiwan and Nichols Brady John, Jimmy Nichols, Melanie Carbone, and Nancy Brown`;
const subst = `\1\4\2\3\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);