$re = '/(\w+)( +and +)(\w+)( +[^,]*)/m';
$str = 'Heather Robinson, Jane and John Smith, Kiwan and Nichols Brady John, Jimmy Nichols, Melanie Carbone, and Nancy Brown';
$subst = "\1\4\2\3\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;