use strict;
my $str = 'Heather Robinson, Jane and John Smith, Kiwan and Nichols Brady John, Jimmy Nichols, Melanie Carbone, and Nancy Brown';
my $regex = qr/(\w+)( +and +)(\w+)( +[^,]*)/mp;
my $subst = '\\1\\4\\2\\3\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";