using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Property?\s+(\w+)\s*(\([^()]+\))";
string input = @"Public ReadOnly Property Test(v as String) As Integer
Public ReadOnly Property Test(ByVal v as String) As ReadOnlyCollection(Of Guid)
Public ReadOnly Property Test() As Integer
Public ReadOnly Property Test() As ReadOnlyCollection(Of Guid)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}