re = /Property?\s+(\w+)\s*(\([^()]+\))/m
str = 'Public ReadOnly Property Test(v as String) As Integer
Public ReadOnly Property Test(ByVal v as String) As ReadOnlyCollection(Of Guid)
Public ReadOnly Property Test() As Integer
Public ReadOnly Property Test() As ReadOnlyCollection(Of Guid)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end