package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Property?\s+(\w+)\s*(\([^()]+\))`)
var str = `Public ReadOnly Property Test(v as String) As Integer
Public ReadOnly Property Test(ByVal v as String) As ReadOnlyCollection(Of Guid)
Public ReadOnly Property Test() As Integer
Public ReadOnly Property Test() As ReadOnlyCollection(Of Guid)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}