import re
regex = re.compile(r"Property?\s+(\w+)\s*(\([^()]+\))", flags=re.MULTILINE)
test_str = ("Public ReadOnly Property Test(v as String) As Integer\n"
"Public ReadOnly Property Test(ByVal v as String) As ReadOnlyCollection(Of Guid)\n"
"Public ReadOnly Property Test() As Integer \n"
"Public ReadOnly Property Test() As ReadOnlyCollection(Of Guid)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")