#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s*([,.!:?])\s*"
Local $sString = "word , word . word ! word ? word" & @CRLF & _
"word, word . word! word? word"
Local $sSubst = " $1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)