package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*([,.!:?])\s*`)
var str = `word , word . word ! word ? word
word, word . word! word? word`
var substitution = " $1 "
fmt.Println(re.ReplaceAllString(str, substitution))
}