using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*([,.!:?])\s*";
string substitution = @" $1 ";
string input = @"word , word . word ! word ? word
word, word . word! word? word";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}