re = /\s*([,.!:?])\s*/
str = 'word , word . word ! word ? word
word, word . word! word? word'
subst = ' $1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result