use strict;
my $str = 'word , word . word ! word ? word
word, word . word! word? word';
my $regex = qr/\s*([,.!:?])\s*/p;
my $subst = ' $1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";