$re = '/(contrat|bail|engagement)(\sde)? (flexible|courte dur[ée]e|sans engagement)/m';
$str = 'contrat flexible
bail flexible
bail de courte durée
contrat de courte durée
engagement de courte durée
contrat sans engagement
bail sans engagement
bail courte durée
contrat flexible de mise à disposition
bail de courte durée renouvelable
contrat flexible de prestation de service
contrat flexible et de courte durée
bail flexible (engagement minimum x mois)
contrat de courte durée (x mois à x ans)
bail de courte durée : x à x ans
bail de courte durée de x mois
bail flexible sur x ans
bail de courte durée jusqu\'au xx/xx/xxxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);