import re
regex = re.compile(r"(contrat|bail|engagement)(\sde)? (flexible|courte dur[ée]e|sans engagement)", flags=re.MULTILINE)
test_str = ("contrat flexible\n"
"bail flexible\n"
"bail de courte durée\n"
"contrat de courte durée\n"
"engagement de courte durée\n"
"contrat sans engagement\n"
"bail sans engagement\n"
"bail courte durée\n\n"
"contrat flexible de mise à disposition\n"
"bail de courte durée renouvelable\n"
"contrat flexible de prestation de service\n"
"contrat flexible et de courte durée\n\n"
"bail flexible (engagement minimum x mois)\n"
"contrat de courte durée (x mois à x ans)\n"
"bail de courte durée : x à x ans\n"
"bail de courte durée de x mois\n"
"bail flexible sur x ans \n"
"bail de courte durée jusqu'au xx/xx/xxxx")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")