// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(contrat|bail|engagement)(\sde)? (flexible|courte dur[ée]e|sans engagement)").unwrap();
let string = "contrat flexible
bail flexible
bail de courte durée
contrat de courte durée
engagement de courte durée
contrat sans engagement
bail sans engagement
bail courte durée
contrat flexible de mise à disposition
bail de courte durée renouvelable
contrat flexible de prestation de service
contrat flexible et de courte durée
bail flexible (engagement minimum x mois)
contrat de courte durée (x mois à x ans)
bail de courte durée : x à x ans
bail de courte durée de x mois
bail flexible sur x ans
bail de courte durée jusqu'au xx/xx/xxxx";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}