import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\;)(?:http|https):\\/\\/s3\\.amazonaws\\.com\\/assets\\.datacamp\\.com\\/(?:\\_|\\w|\\/|\\.)+pdf(?=\\&)";
final String string = " \n"
+ ""slides_link","https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf"\n\n"
+ "https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf\n\n"
+ ";https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf&";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}