const regex = new RegExp('(?<=\\;)(?:http|https):\\/\\/s3\\.amazonaws\\.com\\/assets\\.datacamp\\.com\\/(?:\\_|\\w|\\/|\\.)+pdf(?=\\&)', 'gm')
const str = `
"slides_link","https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf"
https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf
;https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf&`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}