$re = '/(?<=\;)(?:http|https):\/\/s3\.amazonaws\.com\/assets\.datacamp\.com\/(?:\_|\w|\/|\.)+pdf(?=\&)/m';
$str = '
"slides_link","https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf"
https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf
;https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf&';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);