re = /(?<=\;)(?:http|https):\/\/s3\.amazonaws\.com\/assets\.datacamp\.com\/(?:\_|\w|\/|\.)+pdf(?=\&)/m
str = '
"slides_link","https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf"
https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf
;https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf&'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end