import re
regex = re.compile(r"(?<=\;)(?:http|https):\/\/s3\.amazonaws\.com\/assets\.datacamp\.com\/(?:\_|\w|\/|\.)+pdf(?=\&)", flags=re.MULTILINE)
test_str = (" \n"
""slides_link","https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf"\n\n"
"https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf\n\n"
";https://s3.amazonaws.com/assets.datacamp.com/course/intro_to_python/ch1_slides.pdf&")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")