# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!(?:§|[A-Z]+$)).{0,3}(?:[\r\n]+|\z)//gm;t' <<< "§day
DOG
Happy
Monday
Now
Yes
Sunday
§new day.txt
DIY
Leg
Books
Car
Home
abc"