import re
regex = re.compile(r"^(?!(?:§|[A-Z]+$)).{0,3}(?:[\r\n]+|\z)", flags=re.MULTILINE)
test_str = ("§day\n"
"DOG\n"
"Happy\n"
"Monday\n"
"Now\n"
"Yes\n"
"Sunday\n"
"§new day.txt\n"
"DIY\n"
"Leg\n"
"Books\n"
"Car\n"
"Home\n"
"abc")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)