re = /^(?!(?:§|[A-Z]+$)).{0,3}(?:[\r\n]+|\z)/m
str = '§day
DOG
Happy
Monday
Now
Yes
Sunday
§new day.txt
DIY
Leg
Books
Car
Home
abc'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result