import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:§|[A-Z]+$)).{0,3}(?:[\\r\\n]+|\\z)";
final String string = "§day\n"
+ "DOG\n"
+ "Happy\n"
+ "Monday\n"
+ "Now\n"
+ "Yes\n"
+ "Sunday\n"
+ "§new day.txt\n"
+ "DIY\n"
+ "Leg\n"
+ "Books\n"
+ "Car\n"
+ "Home\n"
+ "abc";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}