const regex = new RegExp('^(?!(?:§|[A-Z]+$)).{0,3}(?:[\\r\\n]+|\\z)', 'gm')
const str = `§day
DOG
Happy
Monday
Now
Yes
Sunday
§new day.txt
DIY
Leg
Books
Car
Home
abc`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);