package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/\/(.*?)\/`)
var str = `http://amp.gs/TMjG
https://developer.mozilla.org/en-US/docs/Web/API/Event/preventDefault
http://vk.com/id331639485`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}