$re = '/\/\/(.*?)\//';
$str = 'http://amp.gs/TMjG
https://developer.mozilla.org/en-US/docs/Web/API/Event/preventDefault
http://vk.com/id331639485';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);