re = /\/\/(.*?)\//
str = 'http://amp.gs/TMjG
https://developer.mozilla.org/en-US/docs/Web/API/Event/preventDefault
http://vk.com/id331639485'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end