import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\/(.*?)\\/";
final String string = "http://amp.gs/TMjG\n"
+ "https://developer.mozilla.org/en-US/docs/Web/API/Event/preventDefault\n"
+ "http://vk.com/id331639485";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}