#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)ABSOLVE\b(\(\d+\))?"
Local $sString = "ABSOLVE AH0 B Z AA1 L V" & @CRLF & _
"ABSOLVE(1) AE0 B Z AA1 L V" & @CRLF & _
"ABSOLVED AH0 B Z AA1 L V D" & @CRLF & _
"ABSOLVED(1) AE0 B Z AA1 L V D" & @CRLF & _
"ABSOLVES AH0 B Z AA1 L V Z" & @CRLF & _
"ABSOLVES(1) AE0 B Z AA1 L V Z"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")