use strict;
my $str = 'ABSOLVE AH0 B Z AA1 L V
ABSOLVE(1) AE0 B Z AA1 L V
ABSOLVED AH0 B Z AA1 L V D
ABSOLVED(1) AE0 B Z AA1 L V D
ABSOLVES AH0 B Z AA1 L V Z
ABSOLVES(1) AE0 B Z AA1 L V Z';
my $regex = qr/ABSOLVE\b(\(\d+\))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}