import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ABSOLVE\\b(\\(\\d+\\))?";
final String string = "ABSOLVE AH0 B Z AA1 L V\n"
+ "ABSOLVE(1) AE0 B Z AA1 L V\n"
+ "ABSOLVED AH0 B Z AA1 L V D\n"
+ "ABSOLVED(1) AE0 B Z AA1 L V D\n"
+ "ABSOLVES AH0 B Z AA1 L V Z\n"
+ "ABSOLVES(1) AE0 B Z AA1 L V Z";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}