using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ABSOLVE\b(\(\d+\))?";
string input = @"ABSOLVE AH0 B Z AA1 L V
ABSOLVE(1) AE0 B Z AA1 L V
ABSOLVED AH0 B Z AA1 L V D
ABSOLVED(1) AE0 B Z AA1 L V D
ABSOLVES AH0 B Z AA1 L V Z
ABSOLVES(1) AE0 B Z AA1 L V Z";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}