$re = '/ABSOLVE\b(\(\d+\))?/m';
$str = 'ABSOLVE AH0 B Z AA1 L V
ABSOLVE(1) AE0 B Z AA1 L V
ABSOLVED AH0 B Z AA1 L V D
ABSOLVED(1) AE0 B Z AA1 L V D
ABSOLVES AH0 B Z AA1 L V Z
ABSOLVES(1) AE0 B Z AA1 L V Z';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);