#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:The(?:\s+Travelers)?(?:\s+Companies)?|Johnson(?:\s+\&)?(?:\s+Johnson)?|JPMorgan(?:\s+Chase)?|Goldman(?:\s+Sachs)?|Visa(?:\s+Inc\.)?|Amgen)(?!\w)"
Local $sString = " GS is the main company of Dow Jones <TKR> is the main company of Dow Jones" & @CRLF & _
"1 Once again Visa surprises all Once again Visa surprises all" & @CRLF & _
"2 Johnson & Johnson's vaccine is the best one Johnson & Johnson's vaccine is the best one"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")