re = /\b(?:The(?:\s+Travelers)?(?:\s+Companies)?|Johnson(?:\s+\&)?(?:\s+Johnson)?|JPMorgan(?:\s+Chase)?|Goldman(?:\s+Sachs)?|Visa(?:\s+Inc\.)?|Amgen)(?!\w)/m
str = ' GS is the main company of Dow Jones <TKR> is the main company of Dow Jones
1 Once again Visa surprises all Once again Visa surprises all
2 Johnson & Johnson\'s vaccine is the best one Johnson & Johnson\'s vaccine is the best one'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end