import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:The(?:\\s+Travelers)?(?:\\s+Companies)?|Johnson(?:\\s+\\&)?(?:\\s+Johnson)?|JPMorgan(?:\\s+Chase)?|Goldman(?:\\s+Sachs)?|Visa(?:\\s+Inc\\.)?|Amgen)(?!\\w)";
final String string = " GS is the main company of Dow Jones <TKR> is the main company of Dow Jones\n"
+ "1 Once again Visa surprises all Once again Visa surprises all\n"
+ "2 Johnson & Johnson's vaccine is the best one Johnson & Johnson's vaccine is the best one";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}