import Foundation
let pattern = #"\b(?:The(?:\s+Travelers)?(?:\s+Companies)?|Johnson(?:\s+\&)?(?:\s+Johnson)?|JPMorgan(?:\s+Chase)?|Goldman(?:\s+Sachs)?|Visa(?:\s+Inc\.)?|Amgen)(?!\w)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
GS is the main company of Dow Jones <TKR> is the main company of Dow Jones
1 Once again Visa surprises all Once again Visa surprises all
2 Johnson & Johnson's vaccine is the best one Johnson & Johnson's vaccine is the best one
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)