const regex = /\w+=\S+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+=\\S+', 'gm')
const str = `HTTP_PROXY=http://10.20.30.2:1234
FTP_PROXY=http://40.50.60.5:4567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}