// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w+=\S+").unwrap();
let string = "HTTP_PROXY=http://10.20.30.2:1234
FTP_PROXY=http://40.50.60.5:4567";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}