$re = '/\w+=\S+/m';
$str = 'HTTP_PROXY=http://10.20.30.2:1234
FTP_PROXY=http://40.50.60.5:4567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);