import re
regex = re.compile(r"\w+=\S+", flags=re.MULTILINE)
test_str = ("HTTP_PROXY=http://10.20.30.2:1234\n"
"FTP_PROXY=http://40.50.60.5:4567")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")