re = /\w+=\S+/m
str = 'HTTP_PROXY=http://10.20.30.2:1234
FTP_PROXY=http://40.50.60.5:4567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end