#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(?<=^|[\n;](?:[\t ]*(?:\w+ )?)?)export\s*default(?:\s*(?<modifiers>(?:abstract(?= *class)|async(?=[\S ]))+))?(?:\s*(?<kind>class|const +enum|enum|function\*?(?=[ (])|interface|namespace|type(?! *\{)))?(?:\s*(?<exports>[$_\p{ID_Start}][$\u200C\u200D\p{ID_Continue}]*)(?=(?:\s*[\n({;])|(?:\s*=\s*\{)|$))?"
Local $sString = "export default function () { /* … */ }" & @CRLF & _
"export default async function() { /* … */ }" & @CRLF & _
"export default function* () { /* … */ }" & @CRLF & _
"export default async function* () { /* … */ }" & @CRLF & _
"export default class { /* … */ }" & @CRLF & _
"" & @CRLF & _
"export default async function functionName() { /* … */ }" & @CRLF & _
"export default function functionName() { /* … */ }" & @CRLF & _
"export default function* generatorName() { /* … */ }" & @CRLF & _
"export default async function* generatorNameAsync() { /* … */ }" & @CRLF & _
"export default class ClassName { /* … */ }" & @CRLF & _
"export default abstract class ClassName { /* … */ }" & @CRLF & _
"export default type Options = {}" & @CRLF & _
"" & @CRLF & _
"export default async () => {}" & @CRLF & _
"export default async arg => {}" & @CRLF & _
"export default () => {}" & @CRLF & _
"export default arg => {}" & @CRLF & _
"export default (arg) => {}" & @CRLF & _
"" & @CRLF & _
"export default foo" & @CRLF & _
"export default foo;export default foo" & @CRLF & _
"export default 1 + 1;" & @CRLF & _
"export default {};" & @CRLF & _
"" & @CRLF & _
"declare module 'module-name' {" & @CRLF & _
" export default class ClassName { /* … */ }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
""export default type Options = {}"" & @CRLF & _
"" & @CRLF & _
"/*export default foo */" & @CRLF & _
"" & @CRLF & _
"/* export default foo */" & @CRLF & _
"" & @CRLF & _
"//export default foo" & @CRLF & _
"" & @CRLF & _
"// export default foo" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
" * Resolvable file extensions." & @CRLF & _
" *" & @CRLF & _
" * @example" & @CRLF & _
" * export default async function read () {}" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"export default type Options = {}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")