# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=^|[\n;](?:[\t ]*(?:\w+ )?)?)export\s*default(?:\s*(?<modifiers>(?:abstract(?= *class)|async(?=[\S ]))+))?(?:\s*(?<kind>class|const +enum|enum|function\*?(?=[ (])|interface|namespace|type(?! *\{)))?(?:\s*(?<exports>[$_\p{ID_Start}][$\u200C\u200D\p{ID_Continue}]*)(?=(?:\s*[\n({;])|(?:\s*=\s*\{)|$))?"
test_str = ("export default function () { /* … */ }\n"
"export default async function() { /* … */ }\n"
"export default function* () { /* … */ }\n"
"export default async function* () { /* … */ }\n"
"export default class { /* … */ }\n\n"
"export default async function functionName() { /* … */ }\n"
"export default function functionName() { /* … */ }\n"
"export default function* generatorName() { /* … */ }\n"
"export default async function* generatorNameAsync() { /* … */ }\n"
"export default class ClassName { /* … */ }\n"
"export default abstract class ClassName { /* … */ }\n"
"export default type Options = {}\n\n"
"export default async () => {}\n"
"export default async arg => {}\n"
"export default () => {}\n"
"export default arg => {}\n"
"export default (arg) => {}\n\n"
"export default foo\n"
"export default foo;export default foo\n"
"export default 1 + 1;\n"
"export default {};\n\n"
"declare module 'module-name' {\n"
" export default class ClassName { /* … */ }\n"
"}\n\n"
"\"export default type Options = {}\"\n\n"
"/*export default foo */\n\n"
"/* export default foo */\n\n"
"//export default foo\n\n"
"// export default foo\n\n"
"/**\n"
" * Resolvable file extensions.\n"
" *\n"
" * @example\n"
" * export default async function read () {}\n"
" */\n\n"
"export default type Options = {}")
matches = re.finditer(regex, test_str, re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.