using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|[\n;](?:[\t ]*(?:\w+ )?)?)export\s*default(?:\s*(?<modifiers>(?:abstract(?= *class)|async(?=[\S ]))+))?(?:\s*(?<kind>class|const +enum|enum|function\*?(?=[ (])|interface|namespace|type(?! *\{)))?(?:\s*(?<exports>[$_\p{ID_Start}][$\u200C\u200D\p{ID_Continue}]*)(?=(?:\s*[\n({;])|(?:\s*=\s*\{)|$))?";
string input = @"export default function () { /* … */ }
export default async function() { /* … */ }
export default function* () { /* … */ }
export default async function* () { /* … */ }
export default class { /* … */ }
export default async function functionName() { /* … */ }
export default function functionName() { /* … */ }
export default function* generatorName() { /* … */ }
export default async function* generatorNameAsync() { /* … */ }
export default class ClassName { /* … */ }
export default abstract class ClassName { /* … */ }
export default type Options = {}
export default async () => {}
export default async arg => {}
export default () => {}
export default arg => {}
export default (arg) => {}
export default foo
export default foo;export default foo
export default 1 + 1;
export default {};
declare module 'module-name' {
export default class ClassName { /* … */ }
}
""export default type Options = {}""
/*export default foo */
/* export default foo */
//export default foo
// export default foo
/**
* Resolvable file extensions.
*
* @example
* export default async function read () {}
*/
export default type Options = {}";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}