const regex = /(?<=^|[\n;](?:[\t ]*(?:\w+ )?)?)export\s*default(?:\s*(?<modifiers>(?:abstract(?= *class)|async(?=[\S ]))+))?(?:\s*(?<kind>class|const +enum|enum|function\*?(?=[ (])|interface|namespace|type(?! *\{)))?(?:\s*(?<exports>[$_\p{ID_Start}][$\u200C\u200D\p{ID_Continue}]*)(?=(?:\s*[\n({;])|(?:\s*=\s*\{)|$))?/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|[\\n;](?:[\\t ]*(?:\\w+ )?)?)export\\s*default(?:\\s*(?<modifiers>(?:abstract(?= *class)|async(?=[\\S ]))+))?(?:\\s*(?<kind>class|const +enum|enum|function\\*?(?=[ (])|interface|namespace|type(?! *\\{)))?(?:\\s*(?<exports>[$_\\p{ID_Start}][$\\u200C\\u200D\\p{ID_Continue}]*)(?=(?:\\s*[\\n({;])|(?:\\s*=\\s*\\{)|$))?', 'gu')
const str = `export default function () { /* … */ }
export default async function() { /* … */ }
export default function* () { /* … */ }
export default async function* () { /* … */ }
export default class { /* … */ }
export default async function functionName() { /* … */ }
export default function functionName() { /* … */ }
export default function* generatorName() { /* … */ }
export default async function* generatorNameAsync() { /* … */ }
export default class ClassName { /* … */ }
export default abstract class ClassName { /* … */ }
export default type Options = {}
export default async () => {}
export default async arg => {}
export default () => {}
export default arg => {}
export default (arg) => {}
export default foo
export default foo;export default foo
export default 1 + 1;
export default {};
declare module 'module-name' {
export default class ClassName { /* … */ }
}
"export default type Options = {}"
/*export default foo */
/* export default foo */
//export default foo
// export default foo
/**
* Resolvable file extensions.
*
* @example
* export default async function read () {}
*/
export default type Options = {}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}