$re = '/(?<=^|[\n;](?:[\t ]*(?:\w+ )?)?)export\s*default(?:\s*(?<modifiers>(?:abstract(?= *class)|async(?=[\S ]))+))?(?:\s*(?<kind>class|const +enum|enum|function\*?(?=[ (])|interface|namespace|type(?! *\{)))?(?:\s*(?<exports>[$_\p{ID_Start}][$\u200C\u200D\p{ID_Continue}]*)(?=(?:\s*[\n({;])|(?:\s*=\s*\{)|$))?/u';
$str = 'export default function () { /* … */ }
export default async function() { /* … */ }
export default function* () { /* … */ }
export default async function* () { /* … */ }
export default class { /* … */ }
export default async function functionName() { /* … */ }
export default function functionName() { /* … */ }
export default function* generatorName() { /* … */ }
export default async function* generatorNameAsync() { /* … */ }
export default class ClassName { /* … */ }
export default abstract class ClassName { /* … */ }
export default type Options = {}
export default async () => {}
export default async arg => {}
export default () => {}
export default arg => {}
export default (arg) => {}
export default foo
export default foo;export default foo
export default 1 + 1;
export default {};
declare module \'module-name\' {
export default class ClassName { /* … */ }
}
"export default type Options = {}"
/*export default foo */
/* export default foo */
//export default foo
// export default foo
/**
* Resolvable file extensions.
*
* @example
* export default async function read () {}
*/
export default type Options = {}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);