using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\""language_display\"":\[(?:""1"")\])";
string input = @"{""language_display"":[""1"",""2"",""3""],""quantity"":1500,""meta_display:"":[""1"",""2"",""3""]}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}